Back
Maintenance

Scheduled Maintenance

Completed 6 Nov at 06:00pm AEST.

Application BGL SimpleFund360 Class Super Office 365 QuickBooks (Intuit) SuperMate Xero System Access Email Notifications Core Features
Completed

Maintenance completed

Posted 6 Nov at 06:00pm AEST.
Started

The scheduled maintenance has been completed.

Posted 6 Nov at 03:00pm AEST.